Plugin (wrong font)

49 posts / 0 new
Last post
chkn
Offline
Last seen: 2 weeks 6 days ago
Joined: 8 Mar 2007 - 17:17
Plugin (wrong font)

Thats how the Juce-Demo plugin looks like with the latest tip in Logic Pro:

[attachment=0]jucegui.png[/attachment]

I also have the weird behavior that components with transparant-colour seems to cut out the window, and you can look through the window(?)

XCode 3.2.6

attachment: 

Edited by: user1 on 15 Aug 2013 - 01:47
jules
Offline
Last seen: 8 hours 8 min ago
Joined: 29 Apr 2013 - 18:37
Re: Plugin (wrong font)

Weird.. Is that a music font? I've no idea how it could end up like that!

chkn
Offline
Last seen: 2 weeks 6 days ago
Joined: 8 Mar 2007 - 17:17
Re: Plugin (wrong font)

not idea which font.... I am the only one?
maybe this helps....

[attachment=0]debug1.png[/attachment]

attachment: 
jules
Offline
Last seen: 8 hours 8 min ago
Joined: 29 Apr 2013 - 18:37
Re: Plugin (wrong font)

It must be something that the host is doing that's mucking around with the graphics system - maybe there's some kind of scaling setting? Can't think of anything it could be though, I'm a bit stumped by that!

chkn
Offline
Last seen: 2 weeks 6 days ago
Joined: 8 Mar 2007 - 17:17
Re: Plugin (wrong font)

The behavior is definitly new, didnt't have the problem with juce-tips from the beginning of april.

jules
Offline
Last seen: 8 hours 8 min ago
Joined: 29 Apr 2013 - 18:37
Re: Plugin (wrong font)

I can't think of anything font-related that has changed since then. There's some new CoreText stuff, but that was already there in april..

chkn
Offline
Last seen: 2 weeks 6 days ago
Joined: 8 Mar 2007 - 17:17
Re: Plugin (wrong font)

could you (or someone else) reproduce the issue? Not sure which version i used in april (normally i update the juce source very often)

chkn
Offline
Last seen: 2 weeks 6 days ago
Joined: 8 Mar 2007 - 17:17
Re: Plugin (wrong font)

will try tomorrow to find out since which tip i have this issue

jules
Offline
Last seen: 8 hours 8 min ago
Joined: 29 Apr 2013 - 18:37
Re: Plugin (wrong font)

Thanks, it'd hopefully be simple to understand if we knew which commit caused it.

TheVinn
Offline
Last seen: 1 week 5 days ago
Joined: 29 Aug 2009 - 11:31
Re: Plugin (wrong font)

jules wrote:
Thanks, it'd hopefully be simple to understand if we knew which commit caused it.

Just a guess but...the refactoring of Font and Typeface to support named styles...

sonic59
Offline
Last seen: 3 months 1 week ago
Joined: 9 Mar 2010 - 16:51
Re: Plugin (wrong font)

Quote:
Just a guess but...the refactoring of Font and Typeface to support named styles...

If that is the case, then chkn you should try the last commit of April (9c21813960fb) which is one commit prior to when the font styles stuff was integrated for the first time. You should probably try the commit after that too.
However, by the look of your second screenshot, I'm not so sure that is the problem. The OSXTypeface looks right, it has a proper font name and font style, so the conversion from default font names to actual font names worked fine.

What version of OS X are you using?
Have you tried the plugin in other mac hosts? Do you see the same issue?

Pages