I've finally got around to replacing some bool "send change message" parameters with an enum, called NotificationType.
This means that for a few methods, you'll need to change your code, e.g.
mySlider.setValue (10.0, false); ...becomes... mySlider.setValue (10.0, dontSendNotification);
Old code should cause a compile error, and it's very easy to update. Using an enum to describe the desired effect makes the caller code much more readable that having some mysterious bools there.