Can't build with OSX 10.4 deployment target

9 posts / 0 new
Last post
Mikey
Offline
Last seen: 1 month 1 week ago
Joined: 20 Feb 2009 - 18:36
Can't build with OSX 10.4 deployment target

Normally I wouldn't care about an OS as old as Tiger, but I have a problem. In order to use Pace iLok protection, I must build with a 10.4 deployment target. One of their internal tools requires it. I don't think I can say more without stepping outside of the NDA. I can build with 10.5 and 10.6 targets with no difficulty, but as soon as I change to 10.4, I get build failures with Juce. I'm in XCode 3.2.5 using GCC 4.2 (another PACE requirement).

The sort of complaints I get from the juce compiles include things like AppDelegate::delegate is private (which indeed it is). Errors are not that numerous, but they do stop me dead. I've tried this with the 2.0 code as well as the latest tip. I must think that there are other people on this board dealing with Pace issues. I hope there's a simple workaround, but if not I must plead for a code tweak.

siedschl
Offline
Last seen: 4 weeks 18 hours ago
Joined: 7 Nov 2007 - 09:56
Re: Can't build with OSX 10.4 deployment target

Hmm, JUCE requires 10.5 now, as far as I can see. Kind of a bummer with PACE though... wonder how that will turn out when AAX support is here, as AAX plugins require PACE copy protection.

jules
Offline
Last seen: 13 hours 9 min ago
Joined: 29 Apr 2013 - 18:37
Re: Can't build with OSX 10.4 deployment target

Gah.. Seriously?? When a library requires you to have a newer version of the SDK, then that makes sense, but to stipulate an older one..!?

Anyway.. Try it again now.

Mikey
Offline
Last seen: 1 month 1 week ago
Joined: 20 Feb 2009 - 18:36
Re: Can't build with OSX 10.4 deployment target

Thanks for looking into it Jules. Pace has actually required the 10.4 target for quite some time. When I've got a couple of minutes I'll email you something a bit more about it. While it might be me (it often is), there are still a couple of problems I encounter when building RTAS. The file juce_RTAS_wrapper.cpp chokes on this bit of code:

 #if PT_VERS_MAJOR >= 9
        case 8:   return ePlugIn_StemFormat_7dot1DTS
  #else
        case 8:   return ePlugIn_StemFormat_7dot1;
 #endif

Note the missing semicolon for ePlugIn_StemFormat_7dot1DTS

I went looking for the definition of PT_VERS_MAJOR and found it in the Protools 9 SDK, in a file named ExternalVersionDefines.h. Without starting up the whole Introjucer kerfuffle for the moment, I'll assume that's included in AppConfig.h. I'm still getting a problem in the build, related to a missing CProcessGroup::CreateProcessGroup() in juce_RTAS_DigiCode3. Perhaps this is related to my use of the PT 9 SDK (I've been using it since Juce 1.53). I'll park RTAS for a little while and see where I get with AU and VST.

Mikey
Offline
Last seen: 1 month 1 week ago
Joined: 20 Feb 2009 - 18:36
Re: Can't build with OSX 10.4 deployment target

Still a couple of issues under AudioUnits as well. juce_mac_NSViewComponentPeer.mm (line 561) complains that 10.5 or later is required for zerocost exceptions.

Belay that. Looks like it might be me...

otristan
Offline
Last seen: 14 hours 44 min ago
Joined: 3 Mar 2007 - 14:03
Re: Can't build with OSX 10.4 deployment target

Pace Fusion do not require 10.4 AFAIK. It works fine fine with 10.5 as deployment target.
XCode 3.2.5 using GCC 4.2 is right though.

Olivier

Mikey
Offline
Last seen: 1 month 1 week ago
Joined: 20 Feb 2009 - 18:36
Re: Can't build with OSX 10.4 deployment target

otristan wrote:
Pace Fusion do not require 10.4 AFAIK. It works fine fine with 10.5 as deployment target.
XCode 3.2.5 using GCC 4.2 is right though.

Nope, 10.4 is required for protection builds. That's current information, which I tested empirically.
otristan
Offline
Last seen: 14 hours 44 min ago
Joined: 3 Mar 2007 - 14:03
Re: Can't build with OSX 10.4 deployment target

I have released UVI Workstation and MachFive 3 with a 10.5 deployment target and 10.6 as base SDK.
I'm using GCC 4.0 though.
It works fine for me.

Olivier

Mikey
Offline
Last seen: 1 month 1 week ago
Joined: 20 Feb 2009 - 18:36
Re: Can't build with OSX 10.4 deployment target

otristan wrote:
I have released UVI Workstation and MachFive 3 with a 10.5 deployment target and 10.6 as base SDK.
I'm using GCC 4.0 though.
It works fine for me.

Best go offline with this...